GWTW Forum

Kite Land Talk => Geek Speak => Topic started by: JimB on October 28, 2013, 11:02 AM



Title: OS X Mavericks
Post by: JimB on October 28, 2013, 11:02 AM
What's the scoop?

I skipped upgrading Lion to Mountain Lion, but now see Mavericks is upon us.

Is it a must do, maybe do, or what?

Would I need to finally break down and stick Mountain Lion on this thing first?

Running 10.7.5 on a 11" Mac Air right now.

I've been poking around the web reading up on it, but thought I'd check in with the resident apple geeks.

Thanks.


Title: Re: OS X Mavericks
Post by: boomertype on October 28, 2013, 11:47 AM
Mavericks, is an extension/update of the most current software, you can't skip and go Mavericks.  Apple is offering the older updates at a discounted price at this time. 
I did Mavericks on the first day it was available and it's been flawless. 


Title: Re: OS X Mavericks
Post by: JimB on October 28, 2013, 11:57 AM
From what I'm reading at the moment, it looks like I can go directly from Lion to Mavericks..

"The models must also have at least 2 GB of memory, 8 GB of available hard disk space and Mac OS X Snow Leopard 10.6.8 or higher in order to install OS X Mavericks."


Title: Re: OS X Mavericks
Post by: Allen Carter on October 28, 2013, 12:44 PM
There are a few applications and stuff with interface changes in 10.8 and 10.9, so if you rely on something to work "like it always has" check changes ahead of time for no surprises. TextEdit's new default behavior is heinous. The main issue with a  hop skip and jump upgrade is the greater volume of third party stuff to patch. If you had been running 10.8 a while you would probably have been prompted to update various software along the way. Going straight to 10.9 you may have quite a few things that need new versions. If you're the kind of person who habitually updates SW whether it needs it or not, should be no grief.

Of all the stuff I run the only major package that is a bit funky with 10.9 is Parallels. Just haven't bought the upgrade yet. The old version isn't $50 worth of annoying yet.

Do you really NEED to upgrade? I cant think of anything I'd be missing if I was still at 10.7 (except my fancy MacBook which only runs 10.8 and higher)


Title: Re: OS X Mavericks
Post by: JimB on October 28, 2013, 01:21 PM
It's not so much that I need to upgrade.

Just trying to avoid any future problems.

Mountain Lion struck me as eminently miss-able.

Just trying to determine if Mavericks isn't.

I think I will get it after a suitable waiting period to allow for the inevitable wrinkles to be ironed out.

My plan was to just run Lion out on this machine and upgrade on the next small Air hardware upgrade.

The fact is I really like Lion and don't need all the social inter-connectivity features.


Title: Re: OS X Mavericks
Post by: Allen Carter on October 28, 2013, 02:52 PM
See, that's my limited focus. I've been working with 10.9 since Beta and have no idea what social inter-connectivity features it has.

The main thing we get from a business perspective is some "killer app" that only runs on a specific OS and forces our hand , or new  hardware that moves us up by default. (of course the killer app is almost always something not needed for business but that is trendy)

Notice I say 10.7, 10.8, 10.9? To be honest, I can never remember which dumb cat code name is which. Drives me nuts. Mavericks is easier, partly because its just not a cat, but mainly because if I stand on my roof I can see how big Mavericks is breaking. :P

To totally bring this off topic (slow work day), the very best Apple product code name was BHA.

Engineering had used "Carl Sagan" as an internal code name for a computer in development. Sagan got wind of this and filed suit. They changed the code name to "BHA". When Sagan found out this stood for "Butt-Head Astronomer" he upped the legal ante and things got interesting.  ??? After the courts threw out all of Sagan's complaints, Apple still made a public apology. Legend has it that the third and final code name for the new computer was "LaW" (Lawyers are Wimps)   :)